Tiertime's Next Gen Slicer - Catfish

I guess you can tell F-secure it is not a malware?:slightly_smiling_face:

Hi all.

I’m not criticizing TT here or trying to stir up trouble, I’m simply trying to provide information to aid making things better in the future.

TT products are aimed at hobby users, educational institutions and businesses. I’m a business user and have to comply with GDPR and ISO 27001. As such there are no machines linked to any of our networks that are “exempt from IT policy”. Doing so would get me fired!

Sure, I’m applying for an IT dept. whitelist, but I’m curious as to whether there is anything TT can do to prevent it getting blocked in the first place? F-Secure is an industry leading application so if it’s complaining there has to be something it’s triggering on. I install new applications fairly frequently and it’s very rare for F-Secure to block the install. It would also be nicer for the customers if TT fixed it once vs every individual user of F-Secure being unable to use the software unless they can get an exemption.

Anyway, enough of that, here’s looking forward to trying the new slicer :grinning:

Regards,
Owen S.

one reason would be to invert the axis from 3rd party slicer to work with the selected tiertime machine. but if you get this slicer right the need for 3rd party slicers should be reduced…

looking forward to trying the version after registering!

HI. I tried to register the catfish beta, got the code in email, but when I input the code to the field after i do the “register” command, the aplication tells me to restart the app. But after the restart i still cant export the gcode/tsk as it still tells me to register the app. Is there something i do wrong? do i need to paste the code somewere elese?

The Registration Form has error, can’t send the whole code. We are fixing.

@Jason-TT Are there some instruction on how to use this? I haven’t registered yet but I can load, slice, scale and move models. How can I do the following:

  • Change the view rotation center to properly zoom in and check the slicing? (it always zooms to edge of build plate and I can’t see the model.
  • Place the model flat on the bed without guessing using mx,my,mz commands?
  • Export .tsk file?

The ReadMe file provided is not in English.

It’s great that you’re building a faster slicer but slicing time is not that important especially considering print time far exceed this anyway. Saving 2min on my slice time won’t help my 30hr print too much. That time and more will be lost anyway as I will need to export to .tsk and then import to Up Studio to print.

It would be better to add the options into Up-studio like wall thickness etc. It would be even better to simply fix the infill offset error so that everyone is happy with Up-studio’s slicer in the first place: External surfaces not bonding to infill. Major bug

1 Like

•Change the view rotation center to properly zoom in and check the slicing? (it always zooms to edge of build plate and I can’t see the model.

You can use arrow keys to adjust the view center

•Place the model flat on the bed without guessing using mx,my,mz commands?
Select model by clicking it (or press A to select all), then press P to place in the middle and onto the surface. Then press X and left-drag mouse to move it along x-y plane.

•Export .tsk file?
click the “slice” button and then click the “path” button.

You may refer to download page for more instructions.

We have resent activation codes to users that cannot activate with previous codes, as the submission process cause certain digits to be lost. Now all fixed.

Thanks @Jason-TT for the information. I missed the instructions on the download page.

I’m still unable to register, the code I’ve been emailed did not work. I didn’t receive a resend of the activation code. I’ve tried to re-register can you please check this code.

I just received the registration code (works), but now I get the message when I run catfish:
Can`t load platform file
c:/Users/…/AppData/Roaming/Catfish/Cetus.plat

Okay, registration seems to be working today. I must have been doing something wrong yesterday.

I still can’t get this slicer to Print. I’m getting the following error:
image

In Catfish the material is set to ABS+. My Up300 is also set to ABS+ so they match. How can I get this working?

I’ve also noticed Catfish does not yet support ASCII STL files. It just interprets them as binary and of course the shape is very wrong.

Hello,

You may update UP Studio, make sure the comptuer is accessible to internet, then connect the machine to UP Studio and change the material setting.

For ASCII STL, it should able to support it. If you find any stl has problem, you are welcome to send it to me and we will analyze what happened.:slightly_smiling_face:

I’m running Up Studio 2.6.29.627. Both the printer and Up Studio say the machine is loaded with ABS+ so everything is consistent. Connection to printer is fine.
I can load the .tsk file okay and look at the path in Up studio. When I try to print it sends to the printer but then fails with that message.

The ASCII stil files are from this model: https://www.thingiverse.com/thing:3758189
Up studio has no problem with these files but Catfish shows random faces.

The point is you have to allow UP Studio to download the latest material profiel ID from the cloud and then change the material setting in UP Studio to reset the profile ID.

Ok, how do I know if the latest profile is downloaded?

I dont know, may be keep it connected to internet for 30minutes?
Also please make sure these setting are matching:
%E5%9B%BE%E7%89%87
%E5%9B%BE%E7%89%87

I have them both set to ABS+ in Catfish.
I’ll leave Up studio running for some time and see what happens.

Some off things I’ve noticed so far:

Each consecutive layer when slicing has a different profile width. E.g. if I set “profile” to 2 every 2nd layer has an edge width of 2 but every other layer is 3. I guess this would print okay but I don’t know if it’s intentional.

Also if you slice, change something and slice again the old slicing is still there. So you need to select and remove the old slicing otherwise you get overlapping slicing and you can’t see what actually going on. This happens if you change slice setting or move or rotate a model.

I still have had no luck getting it to start on ABS+. I can however print using the ABS material.
@Jason-TT can you please confirm that using ABS+ does work on UP300 with Catfish 1.2.4_0944883400.
I left the printer and PC idle for an hour but there did not seem to be any material updates.

Settings in Catfish are below: