Z-axis motor seemingly dead

Hey all, first post on this forum. I've been throughly enjoying my Kickstarter printer, and it has really brought the maker in me back to life! Unfortunately I've been having a lot of trouble with it in the last couple of weeks, so I thought I'd ask here for some advice!

Tl;dr (full background below):

* Extruder connector cable came loose during a print, resulting in "Nozzle Too Hot" error.

* Now the Z-axis motor seems to be completely dead. The printer will only initialise if I manually toggle the Z-axis limit switch (and then everything else works fine).

* What do I do?!

Long version:

So, I've been having some issues since I swapped out the build plate with a replacement (the original Kickstarter one was pretty scratched up). The replacement seemed to be quite warped, to the point where I couldn't calibrate the printer to have an adequate nozzle offset across the entire plate.

I had a mishap where the print detached from the bed (I guess because the nozzle offset was too far from the bed at that point), and got PLA all through the heater and nozzle assembly. I scraped it out, disassembled and reassembled, but had to replace the damaged thermal insulation tape (replaced with a silicon tape that is rated up to 260 degrees C).

All was fine for a couple of prints, until the plug came out of the top of the extruder, which stopped the fan running and seemed to cause the heater to overheat. The printer then halted (as it has done before, when the plug came loose), however this time it reported "Nozzle Too Hot" in the Cetus3D software.

I power cycled the printer, and it wouldn't get past the initialisation process. I manually tried triggering the Z-axis limit switch and the printer went ahead and "successfully" initialised the X and Y axes. Weirdly, the extruder motor still seems to work, it's just the Z-axis that is completely dead (no torque at all that I can detect).

I can't think of any causes other than the extruder connector somehow causing a short or other behaviour which fried the Z-axis stepper driver, or maybe just a random failure... But my question is, how do I proceed from here?

I feel quite disabled without my printer - printing things has started to feel commonplace (thanks to this awesome product!) Does anyone have any advice?

A quick update: I just took the top cover off the motherboard, and tried swapping the X-axis plug to the Z-axis driver, and the X axis also refused to work. When I switched it back to the X-axis driver, it started working again.

So from this I conclude that the Z axis driver is dead... Does this mean I need a new motherboard? I'll do some extra exploration tomorrow with my oscilloscope and see if the STEP/DIR inputs to the driver are getting anything (if not, that would imply an issue with the PCB or the CPU), but I strongly suspect that it's the driver that's failed.