Z-axis failing to initialize on new printer. Z-Axis screw all the way down

First off I love my original Cetus3d, it’s a tank - So I ordered a 2nd for work.


turning it on and hitting ‘initialize’, the Z axis motor just tries to
go up constantly and as expected the stepper starts to jump and click. I’ve tried lowering the z-axis hex-screw with out luck. It’s all the way down now.


Any suggestions would help


irgendsowas 2018-1-31 19:50 edit

I'm facing the same issue, 

tighten the belt with two fingers on the bottom does help me.

Try tighten the belt!



First thought after looking your older thread before posting. No luck with this trick. 

Is the crossbar engaging the limit switch at the top of the Z axis? Unless they've changed the design since my printer, you should be able to see and hear the carriage hit the switch at the very top.

Hello!, I have the same problem. He started the Z axis and now the others too. On my printer I don't see the limit switches.
Is it normal that they are not there?
I enclose the photos where you see the point where the screw stops on the shoe.



I was really hoping to log in and see a solution to this problem.  This just started on my printer out of no where which has been fine to date.  Anyone having any luck yet?

I got mine to work.  I just tightened down that screw at the top of the z axis.  I only had to turn it maybe two full turns and then it would not turn anymore.  I then tried to initialize again and it worked as normal.  I hope this helps some or you