Z and Y axis initialization problems

Hi, I just bought a standard MKII printer. The first two times I turned on the machine the axis calibration process worked fine. After that it started not working.

When I do the calibration, the Z axis and the Y axis come to the end and the motors continue to spin making a bad noise.

The same thing happens when I start printing, in the first layer the nozzle presses against the plate.

Why does this version do not have limit switches?

How can it calibrate properly without switches? Can anyone tell me how I can solve the problem? Do I have to request assistance from CETUS?

Thanks so much.


I also have this problem on the x axis at initialisation. It appears to travel to its end point then back about 5mm then makes a horrible coarse vibration which can only be stopped on powering printer off. The claibraion shown here 


has not worked.

Thanks for any help.

Happy Chinese New Year.

I am posting this in case it helps others. 

The problem is fixed.

The x axis was the one that was vibrating so I only applied the black tape to the motor of the X axis. What I have noticed was that the white axis had also come to its stop. 

When I put the tape on both motors the  printer correctly initialised. 

Heres the helpful video again.