Which is the last version of UP Studio software

Hi everybody.
I am using currently UP Studio version.
I looked today in this site and the last released version is I am confused and don’t know which one to use. Could somebody advise in this regard?

I am confused too, I could have sworn there was a newer version online which also mentioned it was compatible again with the ‘‘older’’ printers like Up Box and Up Plus 2. Now the info states you can only use version 2.5 with those printers…

OK, I have that newer version downloaded on another machine. This thread has more info: UP Studio Software

So perhaps that newer version is not safe to use with the older printers although I do not know how the poster got that information.

It would be great if Tiertime would step in and give some info about this so we all know what is going on and what to do.

I noticed the download page said 2.6 was not safe for among others Up Mini 2, but in another thread this was claimed to be fine, so I tried. Initially seemed ok, however I shortly thereafter discovered that the printer would now try to move so fast that it skipped steps. No permanent damage, a few failed prints with layers shifts.

That said I think Tiertime just haven’t quite understoond the major.minor.bugfix versioning system as they’ve been released out of order before, so the current version could well be a new one.

I think that v2.6.34 has been redacted because of problems sending ROM updates through or similar, so my guess is they’ve promoted an older version v2.6.29, as the latest version for now because of various issues including people probably complaining about it not working on their printer still after being promised it would.

V.2.6.29 is not a new release.

I guess they couldn’t admit to that and risk having to send people replacement CPU boards or providing instructions on how to flash through serial or SD card… :man_facepalming:

Meanwhile Catfish died?

Hello guys,

Surprise, Tiertime issued today UP Studio software version Still try to find out how to change the parameters for third parties filaments.
All the best

1 Like

If you launch the matdef program and create a copy of an existing material you should be able to tune that copy to suit your 3rd party filament. The workflow isn’t very intuitive, but it works.

Interesting the warning about older printers is still missing. I wonder if that means they’ve dialed back the rapid move feed rate so it works with the Up Mini again.

Thanks Bjorn. All the best

Anyone else experiencing Catfish activation being invalid after upgrading to

On the bright side it does seem they’ve tweaked the speeds a little, its still much faster but at least it doesn’t skip steps on the Up Mini 2, or not yet at least.

Strange. I haven’t used Catfish since.

It’s a completely separate product so that’s strange that it should be complaining.

Getting a little OT but could be it just expired on its own, along with the other certificates just before new years:P

But seems the UpMini2 can print on any location on the build platform without loosing steps on the rapid moves now, so they seem to be fixing things even if they don’t acknowledge things. So half a thumb up for that!:slight_smile:

Edit; no, that was premature. rapid moves between layers etc are stil too fast and result … so still skipping steps:/

MatDef in looks unusable on my machine - https://i.imgur.com/4P5pusJ.png

The old layout was pretty understandable. Is this a rendering glitch or does it look like this for everyone?

same here. but if you select material at he far top left , then proceed selecting printer, nozzle etc along the top you do get to the material parameters. but I’d look for a new UX guy for sure.

Thanks - I got very confused as I have Up Studio on two computers and have a different UI for part layout as well as MatDef. The .34 version is nicer to use (ditched the model ring for move, scales, etc), and MatDef was very clean and simple. .43 version confuses me as it’s a step back on both, IMO.

I’ve been using .34 with (2) Up Mini 2, and was unaware there were potential issues.

Material editor:

  1. Open the top left menu pane, click the ‘+’ icon next to a base Tiertime made material which your new material will be based on.
    E.g Colorfabb PLA, use the Tiertime PLA profile as a base.

  2. Select printer model. Click on the ‘3D Printer’ drop box, either select ‘Default’ or your printer in the drop down

  3. Enter your material values in the boxes below.
    In the boxes where it says ‘manifold’, one can select this and enter a value which I believe is an override that is used for all layer heights and speeds.
    One can enter specific values per layer height and speed to suit, select a layer height option and speed setting next to the printer model drop down box.
    It’s worth also noting that there are two important temperature values for the extruder. There’s the general print extrusion temperature, and there’s the raft extrusion temperature which is usually higher than the general print extrusion temperature. Be sure to change both values, especially for ABS.

  4. Once material profile creation or modifications are compete, be sure to save the material by clicking on the menu at the top right indicated by the three horizontal bars.
    If you are modifying a material that is already selected and loaded in UP Studio, be sure to select a different material after your changes are saved, and then reselect that material again. UP Studio needs the material reloaded so it gets the updated values in accordance with changes made.


My issue was the rapid moves were too fast, so when printing large parts it would skip steps and layers shift. It could of course be my printer that has unusually high friction from wear and tear - it has terrible resonance, and the axis in question was already replaced once. In any case reverting to 2.5 worked then, and this latest 2.6 version also works, so somehting was likely changed.