UP Studio 3 Vase Mode

I am trying to print the attached image below using vase mode, the original object is solid.

I have made use of the part sub settings to print the bottom using infill instead of vase mode.

As you can see it does not print a top layer and only the bottom and infill. How would I change my config so that I can print a top layer?