UP Studio 3.0 Update 3.0.17 Beta



UPStudio 3.0.17 beta Change Log:

1 Bug fixes

  1. New Functions:
    -1st Layer Feed Ratio

  2. When default profile is being matched, main parameters cannot be changed to avoid confusion. Users need to define custom material to change all parameters.

  3. Add info icon at parameter name to link to knowledge base.

  4. Optimized dual extrusion printing.

  5. New menus button functions:

  • Undo
  • Cross sectional view become usable
  • Add hide list button on menu
  • Able to merge saved tsk files
  • Move: sit on bed become usable
  • tsk files can be auto-palced
  1. Improved preview rendering
  2. Swtich between 2 preview mode by command : view meshpath / view linepath
  3. Add Extruder color option at “Tiertime” menus to give color base on extruder
  4. Add pause layer by command “pause x” x= layer number, paused layer marked in preview.
  5. Improved child model display in path view
  6. Add section preview when configure sub-setting
  7. Add button to switch view mode button model and tsk files (show/hide/transparent)
  8. Child model setting added support and extruder2 modes。


  1. Optimized connection reliability
  2. Added progress bar during file transfer, can be stopped.
  3. Able to override material when tsk and printer material are not matching.
  4. Able to select multiple files, able to select for printing sequentially or print all files in one print job.
1 Like

anything for old printers mid stop problem?

1 Like

This should be solved, if still has the problem please report to support@tiertime.com.


Solved!? I will be testing this out immediately! :smiley:

1 Like

Hi Jason,
do you have plans to release Up Studio 3 for Ipad?

Wand 3.0.17 crushes everytime when I try to send or uploud from desktop for both .tsk and .gcode I am using macbook pro 2017 13" with toucbar.

Hi Ediz,

I use OSX as well and I only experience problems if material is not set in the Wand.


I didn’t notice that thank you so much, now it is not crushing and sending tasks to printer.

Still having main thread blocked errors up studio 3.0.17 beta, which can sometimes be solved by a power down and resume. Replaced the LCD thinking this would solve it. No joy.

Edit: May have been user error. I didn’t uninstall the previous version and I’m pretty sure thats whats happening. let me try one more time.

  • suspect the v3.0.17 install is somewhat error prone lol - it creates an 3.0.16 entry in the Win 10 Apps and Features list and then it reports that it cannot continue install because of previous version…
    Btw - still looking for ‘Extract’ and 'Withdraw 'features in Wand.exe or anywhere in ver 3.0.17 - just saying…

Ran a full 7 hour print last night. Didn’t lock up. Had it set to fine and it was good. Slow as molasses…Immediately after I tried it on normal with some design modifications, and it has now locked up twice around the same layer and spot but not exactly the same spot.

Running it right now on fine with design mods to see if it freezes. Very unmethodological approach but meh, totally not attached anymore. This printer and software has its place.

Edit: that one failed. Main thread blocked error.

The pic below is from me trying to print an up mini 2 fan shroud. That one failed too.

Gonna wipe it and format as card and go back to 2.6 for now.

This does make gorgeous rafts though.