UP studio 2.5 not installing

Hi! So I’ve got the Up Plus 2 without the now “Mandatory” CPU upgrade for using Up Studio 2.6 with no issues. Learnt that problem the hard way.
So now I’m trying to install Up Studio 2.5 on my windows 10 Pro Core I7-4790 and the installation process stops and this legend appears

Any way to solve this?

Thanks in advance

So as a follow up for anybody who might encounter the same problem.

This are the steps that worked for me.

  1. Install version 2.4
  2. Go to config and erease the machine SD card. You’ll get a warning, just continue.
  3. Downloaded 2.5 (had to do this at least 3 times to get it working, good luck) from the official page.
  4. Try to install it. If it stops. Re instal version 2.4, and repeat from there. Very important to download again from server (might be what actually worked)
  5. If you managed to succeed check if in the customize material you get the actual menu or not. If so congrats ,if not maybe try again.

Hope this helps someone. Cheers

I am not even able to download it. I tried it from both windows and os x while other versions downloads with no issue v2.5 is not downloadable 1 time I succeeded to download but that time after the installation no app appeared and I installed 2-3 times. Now I want to try again but again not able to download lol.