Unit of Measure Up-Scaling


When I open a model to print they always prompt me with a message that the model is too small, and is auto up-scaled 25.4 times. I save my .stl files in inches, and this conversion works perfectly well.

Until today. I opened a model (technically “larger” than any of my previous models) and it didn’t auto up-scale. The model was converted to mm, and was nearly microscopic. I manually up-scaled it the 25.4 times and everything is printing fine.

Why would some models auto up-scale and others wouldn’t? Also, is there a setting/feature where my models will just show up in inches, as my CAD files all are? I’m not really unhappy about this little quirk, now that I know how to handle it, but I just wanted to know if this is a settings issue, or just something I have to live with.


I also have the same question. Help is appreciated.

Thanks and Regards,


freejobalert notepad++

Forgive the odd question but if we know Upstudio works in mm why would you export your file in inches in the first place? Why not set the export to mm and never have to think about it again?
Cheers, Owen S.

Because my company uses inches standard, so it just makes sense to keep everything in line with our traditional drafting protocol.

Yes, I could absolutely do the conversion in the 3D model, but I just figured there would be a way to accommodate both systems. If the software only recognizes mm, then at least I know and I will stop wondering. It’s not so much of a problem, just a quirk I wish wouldn’t be there.

Hi, AH-ha, that makes perfect sense. Unitless files are a pain. Makerbot started using proper CAD files for their slicer years ago. I’d love it if TT would catch up with that so we can forget about STL files all together!
Cheers, Owen S.