Tier time software not connecting to 3d printer

The computer recognised that the 3d printer is connected however in the software it says that printer is not connected. please help. been having this issue for 3 days

Please try reseat the SD card on the mainboard, (touchscreen for UP300 and mini 2es)

how do i reset the sd card?

Did it happen after an update? Try installing an older UP STUDIO version on a different computer and see if that can connect to your printer. If it works, then there is nothing you can do to fix the problem computer.

Something in the UP STUDIO software seems to be breaking people’s computers… And it’s pretty much permanent until you do a complete OS rebuild - that is, delete your entire HDD, reinstall windows and then reinstall everything.

Installing an older UP version on the same computer, or rolling back updates, will not fix the issue.

After I have updated them, it worked for a while. During one of the printing, no filament was going out. And I tried printing a new one and that is when it mentioned that printer is not connected. I have tried to reset the sd, but there is no icon where I can reset the sd.

One reason could possibly be because I did not change the material settings of the filament from ABS to ABS+.

If your computer recognizes that your 3D printer is connected but the software is stating that the printer is not connected, I think you should check the USB cable or usb port.

Most of the time software and firmwall of printer is not up to date so check it also. Make sure that the correct driver for your printer is installed on your computer. Try reinstalling the driver or using a different driver to see if that resolves the issue.

Some firewalls can block the connection between the computer and the printer, make sure to check the firewall settings and add the printer software to the exception list. Try adjusting the settings in the software to match the settings on the printer.

If none of these solutions resolve the issue, it may be a hardware problem with the printer or the computer. You can read the guide here. It’s worth noting that this issue could be caused by a combination of different things.