The Main Thread is Blocked with UP Studio 3

Been using UP300 with almost 10kg of filament without any errors like “The Main Thread is Blocked” or “Internal USB connection error” nor other initialization issues.
Wanted to try UP Studio 3 and printer started throwing these errors almost randomly. Sometime, it would take hours before an error appeared. Tried to reseat black/red wires between touch module and mainboard. Tried to run printer with good ventilation, all doors opened, dismounted covers. Temperature never got higher than 40°C. Had no luck. Tried to run UP Studio - version where error never appeared and suddenly - error after error. Restart always helped until next time an error ruined the print.
Ended up with permanent error for longer (more than 30min) prints in both UP Studios.

BUT after resetting printer (Information -> Reset on Touch Screen) errors gone when using UP Studio 2.6 to print. Haven’t try with UP Studio 3, but I assume a printer reset would be desirable as well.

Touchscreen firmware -

you can try the latest firmware 1.5.14, which we optimized CPU resources allocation.
A new reset SD card reset function added in the new firmware, which could also help reduce the chance of main thread block error.

Thank you! Will give it a try.