Strange Initialization Behaviour after changing Flat Cable

My UP300 had extrusion problems. I think the stepper motor is skipping steps, though I was able to confirm it is a damaged stepper. I changed the flat cable with a new one that I had received from Tiertime. When I tried to initialize the printer after that, I got a really strange behavior and was not able to finish initialization. The below is the initialization behavior:

  1. The bed was set to the lowest Home position - activated the bed limit switch (normal behavior)
  2. printer head moved to the back and activated the limit switch (normal behavior)
  3. (something is wrong!!) Printer head moved to the left instead of to the RIGHT and may or may not activate the left limit switch. ABNORMAL behavior.
  4. cannot proceed to print.
    with the new flat cable, no more skipping of steps for extrusion stepper but cannot proceed to printing. Tried a small 20x20x 0.4mm block but print head failed to move to center of bed and got stuck where it moved to. Cannot print.

Trued re-seating the flat cable and even changed another new cable but same result What could have gone wrong and how to fix the problem? Is there a problem with the new cables Tiertime sent me?

Upgraded the firmware to the latest but did not fix the problem.

up300 initialize problem

After some discussions with Joshua of Tiertime, I made some checks and found that the wiring connection of the Y-Axis limit switch was probably loose and thus the system cannot detect this switch and resulted in the abnormal initialization behavior.

I was not able to dismantle this limit switch to check and fix the loose wiring and therefore had to blindly touch the 2 cables (colored ribbon and flex cables) and maliciously fixed the problem. My worry had been since this was only a temporary solution, the problem will come back again. Sure enough. after 2 days, it came back after I tried to print a larger part.

I have not been able to get any advice from Tiertime as to how I can dismantle this Y-Axis Limit switch to properly fix the loose connection or even change the switch if needed and as such, my project has to be put on-hold - Not good at all.

Can anyone here give me some advice/instructions on how to dissemble this Y-Axis limit switch ((on the right side of the UP300) so I can fix the problem?

While I have been generally happy with the UP300 (when it works), i am getting more and more disappointed with the lack of response to this issue - which in my opinion id due to a design flaw on the wiring aspect, being a product designer myself, so I think I have some grounds to say this).

At this moment, I am seriously interested in the UP600 due to its larger work volume, but because it looks very much like the UP300 (at least externally), I’m convered the same flaws are carried over. Any comments here?