So much wrong with the Cetus 2!

Looks like I’m about a month late to the party… my unit arrived damaged so I had to wait for parts to come from China to fix it. They arrived yesterday and I finally got a chance to actually try and work with this printer and slicer software.

First, and foremost, the slicer software is not intuitive whatsoever. Having used many different slicers in my time this is probably one of the worst I have ever seen in terms of usability. With literally dozens of examples of decent slicer software, nevermind some of those being open source and widely adopted by most manufacturers, they went and built the most horrible software they possibly could.

They followed this horrible engineering up with absolutely no user manual (that I can find) and a scant few poorly written articles. Not a single one about how to achieve color changing by using the infill to hide the purge tower, nevermind how to apply color changes to a model whatsoever. I inferred the process of using an image from watching the video on the Kickstarter, but then was unable to get the software to print, save a .tsg or anything useful, even after configuring wifi and Wand for the printer.

So, the Kickstarter said the Cetus 2 would be GCode compatible and that I could use any slicer. Fine. No worries… I switched over to Cura, sliced my model, exported the GCode to the SD, plopped it in my printer but… it wasn’t visible. Took the card back out, renamed the file from .gcode to .tsg, plopped it back in and there it was… visible in the selections. So I chose it, clicked ‘print’ and got an error that it couldn’t use that file anyway. Then, moments later… my printer started trying to extrude filament from a cold tip then started randomly moving about the platform at whatever its current height was as if it was trying to print something… though it was clearly not my model (which was round and these movements were anything but round but rather very random). I had to turn the printer off and back on to make it stop… nothing I did with the touchscreen made any difference.

Ok, so… maybe its just a case of firmware that isn’t updated. Kickstarter said I could do an OTA update over wifi… so let’s give that a shot. Not only does it fail to update with an error code but then it immediately shuts off the wifi and I have to go turn it back on. So, OTA doesn’t seem to work either.

Hmm… well let’s go see if we can download the latest firmware from Tiertime. Nowhere could I find a mention of Cetus 2 on their site except for articles they’ve written, and in none of those articles could I find information on where to obtain the latest firmware. So… can’t locate firmware, can’t update it OTA so… guess I’m stuck with this firmware for now.

Well hell… I guess I’ll try printing one of those models already on the card. Let’s go with the torture test of the articulated dragon. Initialize the printer, run a few passes at leveling (which changed the numbers each and every time - higher and higher, in fact - .98mm!), click print and go on with my life.

Fast forward 12 hours later… went to take the dragon off the bed but there was so much layer separation that it split in several layers and came off in chunks. Great, that went well. Welp, not much else to do but try another model for giggles… lets go with the space ship this time… only a couple of hours to print that one.

Fast forward 3 hours later… wow… what horrible print quality! Literal spikes of filament everywhere, botched color changes, seams that look like the print head stopped at each one and added extra filament for giggles, visible defects everywhere! I have $100 junk printers that do better than this $600 MSRP printer!

Sent support request asking where all the features are, why such horrible print quality out of their own models, how I print gcode, etc. Waiting for a response… they were quite responsive to my support request for replacement parts… even if it did delay being able to use this printer by several weeks so hopefully they can point me in the direction of updated firmware, tell me how to use gcode (which others have said they have documentation coming for that process - which shouldn’t even be a process… it should just load them at the printer like 100% of every other 3D printer I’ve ever owned).

So, came to this forum… found out the mainboards all apparently fail in the same way. Can’t wait for that. That’ll be fun. So far no magic smoke so maybe I’ll be lucky in that department. We’ll have to wait and see I guess. Found out others are having similar issues here as well.

Nothing is as advertised. For a 3D printer from a company that is known for designing them… this is horrible. I have been looking for another anchor for my boat… I think I’ve got one. A very expensive one, but hey… it’s got some heft and should help keep the boat in one place. Aside from that… this thing is useless to me. Can’t get the software to work - don’t have any manuals to guide me. Can’t get it to print my models from the slicer or from the wand server… won’t accept .gcode from any other slicer at the printer. Currently prints horribly and can’t seem to maintain an even bed surface even after calibrating the bed.

Figured maybe other users in the forum had similar issues and their staff would be here solving problems… but no… 30+ days ago are messages asking simple questions with zero responses from Tiertime. Their lack of communication is systemic, it seems, and not limited to just lack of responding on Kickstarter.

To say I’m disappointed in this whole experience would be an understatement. I honestly had high hopes for this product and thought the dual extruder design with OTF switching was a decent alternative to purge towers and swapping filament. I was wrong - this is the worst 3D printer I’ve ever owned… that title used to be held by the XYZ company for selling me one of their horrible printers back in the early 3D printing days that could never finish a print… but we have a new winner of the top spot folks… Tiertime. I will never, ever support another product from this company… even if they manage to get this one sorted (which it doesn’t appear they’re too concerned with doing).

They had a whole extra year to get this done… and they still delivered an inferior product chock full of issues, missing most of the features they claimed it would have, and have zero documentation for any of it.

I now begin my process of reviewing this printer online everywhere I see an opportunity to do so. Nobody should be scammed into paying $600 for this boat anchor. Kickstarter this, Tiertime.


Go to the Facebook group. you can find the answer to your problem.
The problems you mentioned are easily fixable.

Facebook is a chat room with extra steps, it is not a support forum, it is not a manual, and it not able to be used if you don’t have an account. Please don’t suggest it as a reasonable location to get information.

1 Like

So now that I lost another day trying to simply make the CETUS 2 work, I will take some more minutes from my time to hopefully prevent someone to make the same mistake and trust this company.

But I’ll make it short :roll_eyes:

  • Got the Cetus. Tried to connect to my wifi : not possible. Why ? Because of some special carracters in the password. How do I know ? I tried a network with a simple password : it worked.

Emailed Jason about this (7 Feb) : “We are working on this, new update will allow change password of machine when connected with USB.”.

In the mean time I used the USB connection (very unstable) and managed to print some stuff.

As I reguraly check the “download section” I noticed today that there was two “new” firmware both dated on the 7 of April:
1032 : “Original Firmware of Kickstarter Cetus2.”
1038 : " 1. Supported Gcode execution.2. Fixed print stopping issue for some small-size models."

No mention of the wifi problem but I thought that it would be a minor fix. And as it took them 2 month to publich a new fimware I assumed it was fixed.

So I updated to 1038…

Now (on strictly the same configuration) :

  • USB connection is now so unstable that I can’t send a print job (-800 Error Printer NOT Ready). Even auto level calibration is crashing.
  • The wifi issue doesn’t seemed to be solved as I cannot connect to my wifi network (Execution result error : -12203). I can connect to a wifi network without any special caracters in the password but I can’t connect to my office WLAN (with % in the password).

So I tried to print the Frog from the SD card but no matter what I try I get “Chamber too hot” and nothing prints and the printer pauses himself…

Now I can’t print a single thing !!!

Best thing I can’t revert to the old firmware… as I get an error during the process.

This is such a waste of time and money.

@ ddspringle I’ll back any review you publish about this printer. Just send me the links.