Simplify3D profile

smartformat 2017-1-22 12:15 edit

I know some of you have asked for a Simplify3D profile. I had to try out a few settings but ended up with a solid base to build upon.

To use S3D with the Cetus just slice the object and click on "Save Toolpath to Disk".

Then go to Cetus3D Studio, click on the plus icon to add a model and select the saved GCode.

The print should start shortly after.

Download Simplify3D profile

(in S3D click: File > Import FFF profile)


!!! Make sure to set the Z-Axis offset in the "Scripts" > "Starting Script" tab of the FFF-Settings to the value you set in the Cetus3D studio while calibration. Do that by changing the Z-offset in the line "M206 Z-183.4" to your value. This value will alter the offset from the nozzle to the printbead !!!

This profile only was tested with the newest version of Cetus3D ( (64bit Win10)

But it's still not really usable - for test purposes only!



The only problem I can't get rid of are inconsistent perimeter widths.

I printed dozens of calibration cubes and tried different settings in S3D. (Like absolut or relative extrusion distances etc.)

Without luck...

The cube on the left is sliced & printed with Cetus's own software. The one on the right is sliced with S3D.


If someone figures out a solution for this odd behavoir, let me know.

I imported it but see some weirdness, like on the extrusion multiplier and retraction distance, which seem...high.


I'm super new to all of this so it's possible that I didn't do something right. 

[quote][size=2][color=#999999]msim post at 2017-1-14 19:33[/color][/size]
I imported it but see some weirdness, like on the extrusion multiplier and retraction distance, whic …[/quote]

Yes they are way to high, but here ist the problem:

When using Gcode you have to calibrate the extruder, as the printer doesn't know how much steps of the extruder motor translate into the wanted length of pushed filament.

You do that by sending Gcode to your printer to extrude a specific amount of filament and comparing that to the real extruded length of filament.

Then you'd get a ratio to multiply with the extruder's current steps per unit.

Unfortunalty I don't know the default value for the extruder's steps per unit. Also when sending the Gcode command to extrude 100mm of filament the extruder gear would barely turn. The difference between the gcode lengths and the actual extruded lengths seem to be vastly different with the Cetus.

So long story short: I got the weird high numbers by simply test printing and adjusting the values till the result was somewhat acceptable

Thanks for the detailed explaination! Learning a lot!

Have you gotten "motion system error" while trying to send gcode? (where "Printer Ready" is displayed after initialization)

I can't even send a file containing only a simple G28 command without getting this error message. Also, instead of simply homing all axes (or even trying), it heats the hotend (??) and then fails. But, I didn't set a temp in my gcode file. It is literally just "G28" which I would think should simply "re-initialize" (home) the machine. There was no command to turn on the hotend in my gcode file.

I thought the "motion system error" was due to the Simplify3D profile I created but it looks like it's acting like it was with the G28 file. Heating the hotend on its own without reference to the hotend temperature set in the Simplify3D gcode file and then erroring out.

During testing, the hotend started over 250 and I powered down forgetting that the arm would drop...SLAM! Nice.

I'm on version (64-bit).

Did not expect that face to show...that should be Printer.

[quote][size=2][color=#999999]HomerJay post at 2017-1-18 21:53[/color][/size]
Have you gotten "motion system error" while trying to send gcode? (where &quotrinter Ready" is displaye …[/quote]

The G28 command didn't work for me, too. 

I usually got the motion system error when the printer was doing something else issued by the Cetus Software.

Try going to the service panel and hitting stop before selecting any gcode.

Well, that doesn't bode well for the prospect of Octoprint working, does it. Of course, that assumes the USB port is ever enabled to provide a serial connection that can be used by Octoprint/Pronterface and the like. After all, 3D printers are "dumb" as they only know where the print head is relative to where they think the origin is located. And they can only find the origin by G28. I'm not an expert (been at it for about 1.5 years and learning stuff every day!) but I've never sent a gcode file to my printer that didn't start with G28 to make sure the origin is set properly (and end with G28 to park the head home after printing).

I'm not sure I know what you mean by the Cetus software doing something else but I'll see if I can make any progress today. I'll try to stop it before sending an gcode in case it is doing anything. I did find it strange that a simple G28 gcode file would cause the heater to turn on and then turn off. If G28 is not currently supported by the gcode interpreter, then I would think it would ignore the line (in the case of a G28-only file, it should do nothing if it doesn't know that G28 = initialize).

Would be nice to be able to edit my previous dice.

Opened Cetus software, initialized printer, went into "maintenance" pressed "stop" button (it wasn't doing anything anyway). It heated up (still convinced this has to do with the material selected in Cetus and not the gcode file itself...??), threw error and then proceeded to start cooling down.

And here I got a nifty (kinda) custom STL for my Cetus setup so the screws are shown on the bed and the front is indicated with an arrow (kinda...only from the bottom thanks to limitations in Simplify3D and how they apply the custom STL to the print bed). But while it might look good, if I can't use the output files...well.

I did notice that the offset values on the GCODE tab in Simplify3D are used to move the origin around the print bed. You put your printer height in there which raises the origin above the top of the printer in the preview screen so when placing objects they float above the top of the printer area. If I'm not mistaken, the offset in Simplify3D is used to move the origin in Simplify3D to match the location on the printer (front left for the Cetus) so that you are sure placing components in a printable area. For the Cetus, this area is from (-180, 0 to 0, 180) at least as reported by the Cetus software when moving objects around. The printer knows where z=0 is and Simplify3D is telling the printer to go to z=0 (well, 0.2, most likely), not go down by the offset set on the gcode tab.

[quote][size=2][color=#999999]HomerJay post at 2017-1-19 16:02[/color][/size]
Would be nice to be able to edit my previous post…but…no dice.Opened Cetus software, initialized …[/quote]

Cetus said from the beginning that they won't be offering direct Gcode comunication. So I'm pretty sure we won't be able to print with Pronterface or any other program that makes use of a serial USB connection. So lets hope that they release a usable gcode interpreter or Simplify3D profile in the near future.

Your printer definetly acts different than mine. In my experience the "Stop" button cancels all orders (e.g.: previous send gcode files, filament withdrawal/extrude commands...) Also I don't think that the G28 command is essential for the Cetus as it seems to keep track of its position after the first initialization.

Regarding the correct offset values: I tried putting the logic offset values in there but the printhead would move off the printbed and jam the motors as there are only endstops on one side of each rail. The current values are the only ones that worked for me at all.

I do hope they Cetus3D makes an official Simplify3D profile available soon and that there is continued tweaking of the GCode support. 

I was only talking about the z-offset value. My x-offset value is set at 180mm and y-axis is flipped like yours because of how the Cetus prints in the second quadrant (to the left of the y-axis; all x coordinates are negative). If you output gcode from your profile and then set z-offset to 0 and output to a second file, the overall gcode is the same except for a bunch of null layers down to 0. The x,y coordinates that would cause the printhead to move off the bed. This is my first cartesian printer but I'm guessing most don't work in the second quadrant but in the first (where X and Y coordinates are both positive).

I must have missed the part about not offering direct gcode communication. Oh, well. I love the cantilevered design of the printer which is, admittedly, why I went with it. That and it's quite a print volume to printer size which is nice. Guess it looks like a computer transplant will be in order at some point; I won't use it regularly if there is no Octoprint. It's just too handy to have an admin website running on the printer with a camera to view progress from anywhere on my network. An additional advantage is that the noisy machine can be moved from my desk to the basement.

I don't know what is going on under the Cetus software (obviously) but I would assume (I know!) that the software is pretty much doing nothing if all I do is initialize the printer. Maybe instead of "motion system control" they could indicate an actual error. I looked around and didn't see a log file but I could very well have missed it.

For reference, here is what my origin looks like with my Simplify3D profile. So it's in the same place as yours except on the print bed. I think (? I mentioned, my first cartesian printer), that most printers print to the right of the y-axis. I included the bottom picture just to show how the screws from my custom printer stl model are only visible underneath (note how Simplify3D seems to put the printer stl under their print bed). And because stls faces have directionality, the arrow disappears from underneath. If I flip the faces of the screws, they cannot be seen at all. So I suppose at least it's something. Then again, everything will have a raft so I guess I was just playing around, anyway.


[quote][size=2][color=#999999]msim post at 2017-1-19 17:56[/color][/size]
I do hope they Cetus3D makes an official Simplify3D profile available soon and that there is continu …[/quote]

At this point it appears that the interpreter is what needs work. I have a Simplify3D profile which has the axis setup properly (as does the OP). But...the interpreter/sender seems to be buggy at this point. I try sending a gcode with ONLY one line (G28) and it flips out. Strangely the hotend heats up. I was unaware that G28 was the "turn on hotend" command.

Just throwing this out there as another option:

I came across this UP 3D printer G-code converter and have been using it relatively successfully with the Cetus. I have had some issues using the GUI, but none when using the command line operations.

While it doesn't support a whole lot of g-code commands, it has been better than nothing (especially since the Mac version of the Cetus Software does not yet support any kind of g-code translation).

I've also found that using it to adjust acceleration and jerk has been extremely helpful in trying to tweak a decent slicer profile. I have still yet to get a good profile that matches the quality of the Cetus software/slicer, but I'm getting closer!

I'm curious what yall think if you end up giving it a try.

Check it out here:

One thing I noticed during testing that might assist in debugging the problem with gcode processing from 3rd party slicers is that only prints sliced by Cetus3D end up in the log file (in [Users]AppDataRoamingTiertimeLog folder on Windows).

It would be quite helpful if the gcode file submissions were logged as well. Of course this assumes that the log file would contain more info than simply "Motion System Error" which doesn't indicate which line of the gcode caused the issue or why the "motion system" had an error.

Problems remain after latest update ( on WINx64)


Extrusion starts slow every single path and accelerates fast. Long paths will bring the extruder motor to its limits and it'll start digging into the filament.


I got the G28 home command to work.

Also now I don't set the Z-Offset through the origin offset option anymore but through the starting Gcode command M206

Setting the units to mm through the G21 commands seems to have an effect on the retraction- but not on the extrusion settings

[quote][size=2][color=#999999]smartformat post at 2017-1-22 12:09[/color][/size]
Problems remain after latest update ( on WINx64)Extrusion starts slow every single path and a …[/quote]

Any updates on this? Has anyone tweaked simplify3d enough that you're using it instead of the cetus3d software?

+1 for a Simplify3D profile. This is my first 3d printer and I was a little frustrated with the amount of trial and error it took for me to figure out what settings would give me in the actual print especially with support. I either have too much support or not enough. Being able to preview the actual output of my print would save me time and money. We need the GCode support asap or serious improvements to the cetus slicer. Personally I think GCode first then Cetus slicer second.