Scale and extrusion problem

I’m having problems with my Up Box that probably aren’t software related (I see the issues with multiple versions of Up Studio and also the older ‘‘Up software’’ version 2.21).

When I print a calibration cube of 20X20X20 mm one side is about 19.9/20.0 mm but another side is only 19.45 mm - there is also a gap visible between the infill.

I also have underextrusion, I even went back to standard ABS settings which are a bit too hot for my ABS but still you can see a bit through the layers and infill isn’t closed…

I checked the filament, it’s normal as usual and not too thin. I did a calibration reset in the Up software but the problems are still there.

What could this be? I did try the Up Studio Soda beta and am afraid this could have changed some things in the Up Box firmware or something, it’s so strange.

I replaced the CPU and formatted the miscro SD card, used another laptop and still I get prints with wrong dimensions. I checked the print head/belts and it doesn’t really have slack.

Anybody any ideas?

I checked even more things, I lubricated all axes and checked the belts again. Also checked screws and all kinds of parts. The XY gantry seems to have no obsctuctions.

Tiertime, any idea? When I print a small cylinder of 30 mm diameter it measures 29.2 mm front to back (X axis) and 29.7 mm wide/Y axis.

I tried another mother board and USB cable (still no solution) so that leaves little that can be the problem.

Maybe the X axis does have a problem or the stepper motor or something is giving issues like a cable or other electronic board? @Jason-TT do you have any idea?

The under extrusion could be related to the dimensional issue.

But the models are printed too small so I would think there would be overextrusion…

While taking apart the XY gantry the little belt for the X axis broke (maybe it was already worn out) so I ordered a spare and hope that will fix it or else I can’t use this printer anymore - I can’t print for customers with that much dimensional INaccuracy.

you may try rotate from z axis for 45 degree and see what happens.

I have an update on this, it was a terrible job but I completely removed the XY gantry and replaced every belt - lubricated everything again and tightened all screws.

I also replaced the X axis blocks that keep the rod in the back in place - the standard version breaks relatively easy and I updated the STL file for replacement here:

Now the values are much more what they should be and I can use the XYZ axial calibration to get it as close to perfect as possible.