Print Head gets caught on Metal Calibration flap - Help!

I got my printer earlier this year and everything worked great. I printed a Thingiverse Dice tower at 95% Scale the first week and it turned out wonderfully.

Now, after about half a year, I can’t identify what caused it to start misbehaving, but the print head gets caught on the metal calibration flap. I’m nearly failing to print it at 80% size and completely shifted towards the front of the bed.

I don’t know how else to describe the issue and can’t seem to find anything that helps with this particular issue.

There is a Metal flap that sticks up near the edge of the print bed. When you press Calibrate and auto-initialize the nozzle height, the nozzle travels to the back of the print bed and pushes down on this metal flap, that seems to be used to calibrate.

Now, for some unknown reason, even after adjusting nozzle height, It seems the print head gets stuck on this flap and starts to misprint wildly, before failing with a Motion System Error 5.

I’ve reached out to IT multiple times over the last two weeks and haven’t heard anything back.

I don’t know if I didn’t calibrate right, or what, but please help if you can.

Thanks,
Eddie

Edit to add photo - Notice I circled the plastic piece next to the Nozzle on the extruder in the top-left and the metal flap I’m referring to in the bottom right circle. the extruder moves to the left at such a height that the plastic lifts the metal and stops the print from continuing.

Well after reaching out to support over the phone, and twice over email, I still have not received guidance, unfortunately.

However, I at least found an answer by watching a bunch of videos where people showed the printer in action – it turns out the flap is supposed to be completely flat. I used curved needle-nose pliers on the vertical part of the flap to push that towards the screw on the bed to get the flap flat.

I’m printing a model that goes all the way to the back and it worked!