Print Bed - Raft Adhesion Issues

A few days ago I received the Cetus Extended.  Everything seems to work ok except I'm getting a complete lack of adhesion between the build plate and the raft.  I've tried printing six different things and only one didn't completely delaminate from the build plate.   I used the filament provided with the machine.

I purchased the heated bed and, as Cetus suggests, I used binder clips to attach the stock build plate to the heated bed.  (No, the plate isn't upside down.) I've tried printing with the bed on or off.  I've tried upping and lowering the print temperature 10-15 deg.  The raft starts to delaminate from the print bed after the second pass.  All the prints fail very early.

I wonder if this particular machine didn't get the stock print bed with the "special coating."  Is there a way to tell?

I purchased this machine based on reviews.  I don't want to be a "3D print guy".  I purchased this machine to further my other hobbies.  Therefore I just want something that works.




It's fairly easy to make sure you got the "special coating". If you look at the bed it will have what almostvappears to be an eggshell surface and if you rub your hand across it you can definitely feel it is not just a smooth piece of metal.   As far as bed adhesion have you tried adjusting the nozzle offset?  Perhaps the first layer is not being "squished" enough causing the poor adhesion.  Good luck, I hope you get it working because it's a great little printer. 

What temperature are you using for PLA?

Are you using the Cetus3D-software and are you printing slts or g-code? Did you check your calibration in the Cetus3D-software?

To answer the three people from above:

  1. Based on your description, I believe the bed has the coating.  It just doesn't stick.

  2. My first few print attempts were used via the "simple" calibration suggested by Cetus.  The raft was a bit wonky.  After a couple of failed prints, I did the nine-point calibration and I'm sure there's enough "squish" on the first layer.  It's better than the industrial 3D printers to which I have access at work.

  3. As for temps, I've tried:  200, 210, 220, & 230 with no luck.

  4. I'm using the Cetus software with default settings (unless otherwise stated).

  5. I'm printing .slt files.  But that's not really an issue.  The issue is that the first layer of the raft doesn't adhere to the bed.

I've read that diluted, white, school glue works well, so I'm trying that.



Hi again. I've never had to with my Cetus but on my DaVinci printer which has a glass bed I use a simple glue stick which would probably be a lot easier than white school glue. And again I'm just spitballing here as I've never had an adhesion problem. Original Kickstarter Cetus without heated bed. 

The printer was creating the raft for a print I has set up using diluted Elmer's white school glue as an adhesive.  Unfortunately, during this print the Cetus' electronics took an apparent crap.

The machine has power (cooling fans run, blue LED illuminates), but is completely unresponsive through USB, wifi, or the front reset switch.

So now I have two issues, one much more of a problem than the other - getting Cetus to recognize the issue and provide me with a solution/fix.

I bought a Buildtak surface as my normal coated one had problems with adheasion. It did not help much at first but then I tried raising my print temperature to 230 and now it sticks extremelt well. (Using Luxorparts PLA, rated for 190-220 degrees). I have to use the little cetus pliers to losen a corner from the bed before I can get the spatula in there and separate the model.

Looking around the forum for the same problem. Found your reply on using 230 C? on Luxorparts PLA, exactly the one I use! Thanks, now for some testing...

I can confirm really good adhesion with PLA on a Buildtak surface and 230 C.