No extrusion possible with new Cetus3D

Hi everybody,

I just received the Cetus3D and assembled the parts together. So far it looked fine (slightly bend motor mount as other have also noticed from shipping) and after height calibration I tried to load the PLA. In the maintenance menu in the software I tried to press "extrude", then the motor tries to shove the PLA into the nozzle but stalls repeatedly. No plastic is coming out of the nozzle. I tried this after turning the printer on and off again but no change. 

The thermometer in the software shows temperatures between 398 and 205 degrees but I can easily touch the nozzle with my finger and it does not even feel slightly warm. 

Do you have any tips how to fix this or is the printer broken?


Check the electrical connection is good to the print head. Seeing super high temperature like that without any actual heat is a good indication it is not plugged in all the way.

Thank you Adam, I made sure that the plug on top of the print head is plugged in all the way. This did not change anything but I wiggled the yellow heat-shrink tubing going to the nozzle. This dramatically influences the temperature reading, it jumps between 35 and 400 degrees. So something is definitely loose there. 

Is there anything else I can do?