Need to re-calibrate every printer is turned off


I am new to printing. I have to recalibrate the Cetus every time I turn it off. If not recalibrated after turning on it will cratch along the print plate. Did anybody experience the same and might have a solution?



could be SD bump out of place and unable to save nozzle height value, please try reinsert the onboard SD card.

[quote][size=2][color=#999999]JasonWu post at 2017-9-20 03:15[/color][/size]
Hello,could be SD bump out of place and unable to save nozzle height value, please try reinsert the …[/quote]


Thanks. That seems to have worked.


feltwicked 2017-9-23 11:55 edit

I'm having the same issue. I would like to adjust the SD card but I have no idea where it is. How do I access it. Can you post an image of its location? The user manual seems to have been written fo people who already know how to construct these printers, and not for those who actually need to reference the manual like me - completely new to 3D printing.

UPDATE: I located the SD card and removed and reinserted it correctly. I then recallibrated the build plate using the manual system. I printed a model 20mm cube. It dis not scrape on the plate. After successful printing I turned off the printer, waited 2 minutes, turned it on again and intialised the printer. I then attempted to print another 20mm cube but the nozzle scaped on the build plate again. I checked the calibration numbers and they were exactly the same as when I calibrated after reseating the SD.

Now I am even more confused. Why, if the calibration settings are the same, does the nozzle scrape the plate after the printer is turned off then on and initialised? I have updated to the latest version of the software v 64 bit Windows 10 version.

How much variation do you get between 2 calibrations? for exmple when have 170 as the nozzle height, then turn off and reinitialized the printer, go to calibration and should see the value to be 170 as the value is save in machine, but this time it should scrape the build plate somehow and need to recalibrate, so much is the difference?

Hi Jason,

Here are the calibation settings images.

Calibrated and working (before turning off and re-initializing):

2017-09-24 before.png

And after turning off and initializing.

2017-09-24 after.png

[quote][size=2][color=#999999]feltwicked post at 2017-9-24 00:59[/color][/size]
Hi Jason,Here are the calibation settings images. Calibrated and working (before turning off and re- …[/quote]

Second image is after recalibration (manual). The calibration settings before recalibration and after initialisation were the same as the first image, so the SD card is remembering the settings, it seems as if the build plate  mechanism is adjusting itself when turned off.

feltwicked 2017-9-24 10:06 edit

OK, here's a really confusing update. I just finished a 5 hour print job. I then immediately started another model using the same parameters, the nozzle started dragging along the build plate. I know the wifi connection was lost once during the 5 hour print. I've reattached the USB cable to prevent connection loss in case this is the cause. I've tried to re-calibrate manually again but now the manual recalibration at position 1. will go to 171.9 then drop to 166.9 immediately allowing no fine control. In position 9. it does the opposite and presses down to 190.0 then the printer looses connection and I have to restart the printer and the Cetus software. This is beyond a joke! The printer prints well, and I really want to use it but with these continuing issues, along with a deeply scratched build plate on delivery, I'm thinking of claiming it a dud and demanding my money back.

Screenshot of the current calibration settings. note that position 9 is not accurate as it won't accept a proper calibration.

2017-09-24 after 5hr print.png

JasonWu 2017-9-24 10:15 edit



These number are not normal, for 9 point calibration the compensation should be limited to 2mm, but you are getting value way off the limit. I am wonder it is input manually or somehow come from the software? Also your platform movement should be limited to nozzle height, but you are moving lower than nozzle height value.

I believe something is wrong with machine, you may contact for further asistance.

This is a shot of the recalibration after I uninstalled then reinstalled the software.

2017-09-24 after reinstall software.png

I wonder if that dimmed Auto Level butto has a function in this softer or definately not. it would be at least nice to have the software accoplish this boring and critical setup. I'm not able to get one eight and keep this same one one each and every use. Every time I start the printer with the latest settings (well stored on the sd I suppose) I get the nuzzle engraving the bed... I wonder if this cetus3d born as a CNC machine instead...

Hello MrRichardB,

Please contact support for this problem, this is not normal.