MKII Extended X-Axis Post-Homing Problem


I’ve had my MkII Extended for awhile now but, recently the bed has a problem while homing/initialization. While the bed slider correctly stops at the motor, when moving away, it gets stuck and is unable to move even with help. This happens within a centimeter of the motor and in the same spot every time. I’m not sure what I should check or if I need to replace anything.

Here’s video of the problem: Cetus 3D mkii Extended X-axis Problem - YouTube

Any help is appreciated!

<p>Check the belt and the bearing end. You might have lost a tooth on the belt or more likely you have foreign material in the belt which is binding in the pulley due to spring tension as the stepper runs under reduced torque while homing to take full advantage of the current load sensing for homing. Never had it happen on my Cetus but the Cetus is newish (~100 hours run time). I have thousands of hours on my laser cutter, and have had to its crap belts with proper Gates G2’s due to lost teeth, it also uses current sensing stepper drivers for homing and any little thing will set it off during homing, but it will drive through (which is worse things get broke that way on that machine,) during normal speeds and feeds.</p><p>My Cetus came with genuine gates G2 belts (good) which have higher aramid fiber content than some of the no-name belts, which means tougher/less stretch, more reliable.</p>

<p>Just a follow up:</p><p>I was blind and the noise came from when the X-Axis tried to home but failed to detect, stop, and move back. On that motor I had one piece of the black tape on it. It was fixed by removing that black tape. I guess it had changed its mind on wanting tape there since I also tried to add more pieces of tape with the same results. Anyway, it’s fully initializing now.</p><p>Thanks for the suggestion jringloff, I checked the belts and dusted them which couldn’t hurt to do anyway. </p>