I'm having problems with this "Data transfer failure. 2"

This only happens with certain prints, but sometimes I get this error when slicing. I've tried over and over to get this low poly Charmander print to work but every time it gives me the error. Benchy worked just fine, my vase worked out fine as well, but now im having these problems. Even when my printer isnt connected it wont even preview the print like it would for benchy. charmander_low_poly_pokemon_flowalistik_preview_featured.jpg

I wish I knew the answer. I have the same thing happen EVERYTIME I try to print a simple basket and I know the basket is structurally sound.

Ive been trying everything and sometimes it seems to work ok and sometimes it doesnt out of pure whim. I change nothing and sometimes it just refuses to slice.

I have found that I get this error when the internal micro SD gets full.  I can eleinate the problem by going into "options" and "delete downloaded files"

It may sound stupid but quite often this error is fixed by simply moving the piece to a different spot on the buildplate.  Other thing is similar to what Glueguy mentioned but make sure the SD card is seated properly.