Ignored my Cetus for a few months and now it won't print

HomerJay 2017-6-13 05:18 edit

The kit printer I built a few years back has been cranking out parts so well it's been my go to printer for the last few months. But I ran some wood filament through and it clogged. It's been a while since I've even powered on the Cetus. But now that I'm trying to use it, what was once a decent little printer is now not working.

I think I'm past the first issue I had where it wouldn't recall the calibration and thought it was at zero and a zero height printer. It now seems to recall the calibration after power down. This is good since I need to move the printer near my computer whenever calibration is required.

Now that I'm past the zero height printer, whenever I slice, I get an error message regarding insufficient filament in the printer (BTW, please remove this check or at least allow for an option to disable it!! I can see how much filament I have left on any given roll and if I run out during a print, honestly, who cares?). I get the message twice near the end of the slicing before Cetus Studio tries sending the data to the printer. Both times, I click OK.

Cetus Studio then starts to send commands to the printer. This is where the critical failure occurs. In the bar across the top (where Printer Not Intialized is displayed upon initial load), the message now reads Save to SD Card and I receive a dialog indicating "ERROR: Data Transfer Failure (6). Fail to send cmd to printer."

Additionally, while not a critical issue, the display name which once was the serial number is now part of file path and some Chinese characters (currently it reads "rogramFiles=C:P???").

I have tried to uninstall and re-install the software and am running version In the meantime, I'll try to see if I have an older version of Cetus Studio lying around.


I suspect that the SDcard on the motherboard is loose. This guess is because it's been an issue for others.

The one thing I didn't try was messing with the SD card. I can't imagine it would have loosened by my moving the printer up and down the stairs twice. I did add the grounding cable (mine is one of the first machines) before trying to use it this week. Probably would have been a good idea to check then. Whoops...

Thanks! I'll see if that's the issue when I get back into Windows.

HomerJay 2017-6-14 00:28 edit

Sure enough, the SD card was not seated. Looks like a sketchy batch of SD card components. Seeing as how it's a SD slot that requires pressing in to unlatch and remove, once in there, it really can't be pulled out. It did take a few times to be confident it was seated; not near as smooth as other SD slots on other devices.

It's back up and printing without issue now. Seat the SD card properly and it's a whole different printer!! No alert regarding low filament, it recalls configuration, serial # is once again the display name and no more comm errors.

And it's even (finally) running on Wi-Fi!

Excellent. Everytime people have had weird behaviour, the seating of the SD card seems to be the culprit.