How do you add custom materials in Up Studio 3?


Please excuse me if this is a silly question. I am trying to add a custom material in Up Studio 3.1.1 but I can’t seem to get it to work properly.

I can go into the machine settings, Material tab, and add a new filament. But as soon as I select the new filament that I created in the filament selector at the top of the screen, I get an error message “No Matching Parameters” and the bar becomes pink:

After this I CAN send the print job to Wand, but Wand doesn’t know about the new filament and seems to use the settings for one of the default filaments instead of the new custom one.

I have tried saving the .tsk file for the print job and importing the filaments from that file into Wand, but it doesn’t have any effect at all and the new filament type doesn’t appear.

Am I doing something wrong? Have other people gotten around this somehow?

I have an Up Plus 2 connected, but the same thing happens if I select any of the other printer types.

Adding a custom material works in Up Studio 2, but you can’t really change much… Up Studio 3 would be
very preferable.

Thanks for any help!


Just to correct myself on this. Adding custom materials in Up Studio 2 does NOT work. After printing 4 benchies I have realised that the print temperature settings are ignored, and the nozzle temperature (hidden while printing, but visible just before and after printing) is always fixed at 270C. So that was a waste of 12 hours.

It seems the Up software really does deserve its bad reputation.

I was able to get a custom material into wand by setting it up in UPStudio 3 expert mode and then applying it. Next I input a model and selected the material on top and sliced it. Then on the sliced file on the left use the save icon to save the tsk file where you can find it. Open wand and choose edit and choose import from tasks (the file you saved).
That worked for me, but I’m having trouble with stringing and can’t make sense of the retraction settings. They don’t use the normal retraction length settings, they have Max length, Min Travel (is this the same as min travel distance?), and “Ratio: Actual retraction length = Ratio* Travel”. What travel are they referring to? We really need a tutorial on how to set up the materials in UPStudio 3.

1 Like

I have the same problem. Why is TierTime not responding to this and correcting it. Are they forcing us to use their material only. If so, I will never buy or advocate a TierTime product ever again.

UP studio 3 current release is too complicated at synchronizing materials, a new version will be released soon to solve this problem.
Current version material import:

  1. duplicate an existing material and change the settings you want.
  2. change material on the top bar and do slicing. no matching parameter means, there is no preset profiles can be found, so the software will not able to auto select print profile/nozzle/layer combination for you. This is expected as it is a new material and its current setting is a copy of a default profile.
  3. Save the sliced data into .tsk file.
  4. Open Wand module, go to material=>edit=>import from task=>select the newly defined material and move it to printer side.
  5. In Wand click “print” => print task=>select the task file


  1. Open Wand module, go to material=>edit=>import from task=>select the newly defined material and move it to printer side.

When selecting “import from task” which folder do I locate the newly defined material?

Thank you

From the folder you saved the sliced data .tsk file to.

I have my sliced files going to my desktop in a different folder.

Is the folder in program files? What file type is the new defined material?

Thank you

  1. Open Wand module, go to material=>edit=>import from task=>select the newly defined material and move it to printer side.

When I do this. Nothing appears in the window to be able to move to printer side.

How do i fix this @Jason-TT

Basic materials / temperature management should be more intuitive. Especially the relationship between the slicer and the Wand thing needs improvement.

Also, this has been asked many many times over the years. Need to see actual temperatures in the Wand app. Not 89%. 89% of what? Should say set temperature and actual temperatures clearly in degrees. Then you can add the percentage and whatever else people think they like to see.

1 Like

Still no answer from TT referring the definitions of Max Length, Min Travel and Ratio? And is more than a year since was posted. Shame on you TT. This is a wrong attitude. This Studio 3 has so many data to be adjusted and due to the Chinese definitions Studio 3 is more confusing than helping. Very strange behavior TT.

Are there any update on this subject?
Or an guide to the workaround, do i need to export my custom materials from up2 and import them in up3?

You may need to manually copy the settings, there is no way to directly convert the settings.

This was a complicated enough procedure that I wrote myself a guide because I’m going to forget the next time I need to do this.
Hope this helps others.