HELP! My 6 year old BOX+ has DEACTIVATED ITSELF!

I have a BOX+ printer that I purchased in 2018 that seems to have become deactivated somehow and won’t let me print. I print professionally and this has been my main machine for over six years. It is now just a big paperweight until this issue is resolved. :angry:

When I log into my account, the printer shows as being activated as you can see from the screen shot below, but its giving me the “print number limitation” message as if the printer is not activated. I am using an older version of Studio that has been working well until now (x64_2.5.12.459). I also tried using the beta version (3.2.7) and it gives me the message “printer needs activation”.

The software starts and initializes just fine and shows printer is ready. Just won’t let me print anything. I have orders to fill and my little business is basically dead in the water until this is fixed. What could be causing this?


Update…

I have done a repair on the driver and uninstalled and reinstalled the software which had no effect on the issue. :worried:

This appears to be a problem within the printer (ROM?). I’ve searched and there appears to be no firmware downloads or updates for the printer, so I’m not sure what else to try at this point. I’ve also sent in a support request to Tiertime with no response as yet.

:blush::+1:

Alright, got a response from support yesterday morning and it did turn out to be a CPU ROM issue. Cecelia with Tiertime sent me a CPU Tool app to flash and reset the ROM, which worked like a charm, so issue is solved. Thanks Cecelia!