Getting "Printer Not Connected" working once again. HOWTO

OK, So my printer hasn’t worked for about 3 to 4 months. Ever since the auto-update. It’s been a disaster. I’ve found LOTS of other people with this fault, and the only solution is to reinstall Windows 10. Clearly not an acceptable outcome.

After deleting stuff, reinstalling dozens of times, and cleaning out the registry by hand, I’ve finally discovered it’s not the computer. ITS THE PRINTER. It remembers which computer it was attached to for some reason. And it refuses to work with that computer. THAT"S WHY IT"S SO HARD TO FIX…

So here’s my solution - if you have the problem where the printer is recognized, it flashes up the serial, then the filament type, then says “Printer Not Connected” and the filament type goes away and leaves the serial, and you can’t detect the printer on Ethernet, Wifi or USB.

First, get hold of some REALLY old software. Here’s the ones I found on my HDD.

Downgraded Studio to 2.5.0.431
Downgraded Touch Panel to 1.3.14

That goes back to around 2018.
When I did this, it worked, but badly, so I did a reset and it still worked badly, but at least was recognized, but needed calibration before functioning.

Now, I ran the software and updated to the latest version, leaving the printer Touch Panel alone. This updated the software and start bringing up errors ( as expected ).

Now I updated the Touch Panel to 1.4.9W, and restarted.

This time I got the error “Printer Not Initialized” ! Woohoo ! Initialise from the PC and it all works.

Then I spend 30 minutes figuring out why nothing works even though it can see the printer now, and realize all the numbers in the printer are zeroed out, so I do a platform height check and manual calibration with the card, and it all works now, with the latest software.

So something in recent versions remembers what computer it was talking to, and when it screws up, it won’t connect to that computer anymore via ANY interface. USB fails. Ethernet fails. Wifi fails. Nothing works.

But going back to some early 2018 versions seems to ignore this, and everything starts working again. I suspect if I did a calibration it would have stayed that way, on version 2.5.0044 or something like that, but anyway, after that, I was able to do a clean upgrade and install new firmware and it all works now.

Hope this helps someone else with the problem, and helps Tiertime work out what is causing this for future problems users have. I hope I’ve described it accurately enough.

1 Like

Thanks for your feedback! This can help others so it’s great you took the time to share this info.

So it failed again a few days ago… Ended up on chat with someone from Tiertime who stayed back to help, and he offered a LOT of suggestions, none of which worked, however a few I couldn’t try. This included new software revisions, not available from Tiertime downloads.

So I eventually reboot and a few other things, and come down to the last option. Move the USB port. So I get another cable, since my USB and Ethernet are relayed through to the printer, and plug it in, and it works. Take it out, ethernet only, fails again. Plug USB back into another port - works. So it’s still like the printer remembered the old port it was plugged into and moving it made a difference. It’s a bit frustrating that it still doesn’t work with Ethernet ( although only the computer I need it to work with is affected - others with older software are fine ) but moving the USB port after upgrading everything, if nothing else works, is recommended to try.

There’s nothing wrong with the old USB port - that works just fine too. But for some reason, something remembers that particular port and just doesn’t like working with it - I suspect it’s cached in the printer somewhere. If only I could factory reset my printer, I think that would fix it too. But, for now, some more information to help anyone affected.

Just to add - the “move USB port” suggestion did come from Tiertime. It wasn’t something I randomly tried.