Cetus Mk3 USB Connection Issue

I have been printing for approximately 2 weeks using UP Studio with my new Cetus Mk3 Extended Printer. I ordered all the upgrade kits from the Tiertime store (extension board, heated bed, leveling probe, and extruder v2). For 2 weeks everything was working great. My upgrades arrived and I installed them yesterday. Then the following events happened:

  1. Installed new 24V supply, and heated bed.
  2. In the software when my printer was connected I noticed its name was displayed as the serial number. I went into the settings and renamed it “My 3d Printer”.
  3. I uploaded a calibration print and started printing.
  4. The display at the top showed the extruder reaching its temperature but the heated bed stayed at room temperature. Approx. 20 degrees (40%).
  5. Apart from this the print started as expected, and was working.
  6. Stopped print to investigate why the newly installed heated bed was not working.
  7. Opened the maintenance window and clicked the pre-heat bed button. The display along the top showed it was attempting to heat the bed, (red thermostat icon was moving upwards, but the temperature was steady at 20degrees.
  8. I suspected the ribbon cable was somehow at fault.
  9. Closed the software (UP Studio), removed power to the Cetus printer, removed USB cable, unlatched the ribbon cable from the heated bed and expansion PCB.
  10. Checked the continuity of the ribbon cable with my multi-meter but all pins returned 0.5Ohms resistance.
  11. I re-installed the ribbon cable, power supply, and USB cable.
  12. Re-oponed UP Studio and now I can no longer connect to my printer. The top display shows “no printer connected”
  13. I tried downloading the CPU rescue.exe and again it just says no printer connected
  14. Opened windows device manager and when powered on there is no COM Port detected.
  15. I have checked the USB Cable and it works with other devices (programs Arduino’s, prints regular laser printers).
  16. When my Cetus is powered up the internal green LED is on and the front Red LED is also powered on. But there is no data being sent to the computer through the USB cable.
    What are my options on getting the USB communication re-established with my printer? Does Teirtime send replacement boards? Also why was my heated bed displaying temperature but not heating up?