Cetus MK3 strange movements, x axis crash, no prints possible; Need support

Hello dear Cetus community,

I bought a Cetus MK3 half a year ago as my first 3D Printer. It worked perfectly fine and produced nice prints without any fiddling around. I even got the extension board, 24V psu, heated bed and auto probe later, all working fine.

But now since last week I got some very strange problems out of nowhere!
It started with the Cetus making random “beep” sounds from time to time. Later that day Cetus just stops in the middle of the print, drives the z axis to the top and stops. I could not resume the print and UpStudio shows me a “Motion System Error Z” error. I had to throw away the print and start again.
But I could never finish the print (1-2 hour print time). It always stoped at some point in the print with “Motion System Error Z”.
I turned off the printer and wanted to see if I have better luck the next day…

But the next day, things got even worse!
The Cetus went completely mad now.

I made four short videos to show you the problems.

In the video you can see following problems:
-“Motion System Error Z” in UpStudio (sometimes I also get “Motion System Error” for X and Y axis as well…)
-“Model Out of Print Range” in UpStudio although its clearly not!
-X axis is crashing in end of axis! But it only happens sometimes, sometimes not…
-Printer is initializing immediately after turning it on and then doing random moves… Really strange.

I tried following things but nothing helped:
-Connecting printer via USB instead of WiFi
-Tried different 3D models/STL
-“Clear Cache file” + “Clear downloaded models” in UPStudio
-Checked all motor cables + end stop cables. All Pins OK, reseated all connectors + tested with multimeter. All OK.
-No broken parts visible on mainboard.
-Initializing the printer is working. Motors are moving + end stops react.
-Removed the extension board and heated bed and used the original configuration.

I don’t know what else to do. I basically can not use the printer anymore at the moment.

I already have opend a ticket for Tiertime Support (16546) on Jul 2. Jason Wu only reacted once to the inital request but never came back to me after I sent him the videos, although I send daily reminders to them!
@Jason-TT Please respond to my emails or this forum post. I’m feeling a bit ignored right now…
@Cetus-Comunity If somebody here has any idea what else I could test, I would much appriciate it.

Best Regards

@Mambu , I viewed your videos, and although I have not experienced the same events, I have a few thoughts that may help you.

  1. UPStudio program files might be corrupt on your computer hard-drive, or the temp files UPStudio uses might be corrupt. I would run a diagnostic to check your hard-drive/s files for errors, and also include the check for unused spaces for physical errors. This may correct the errors you see within UPStudio, and also any IO to the printer. I would also check the sd storage card on the printer.

  2. Uninstall UPStudio and re-install. Make sure to delete any temp files, the folders and anything related to UPStudio.

  3. If the above does not correct anything then, it could be that electrical signals are becoming corrupted somehow. Make sure all wires are rerouted away from all the stepper motors, and there is distance between all wires, including the wires not related to the printer in between your computer and the printer. You might also turn-off all electronics devices except for the printer and then turn on the printer and initialize the xyz.

I’ve seen some strange things happen with electronics in my days, from misbehaving microwave ovens 30 feet away messing with electrical signals, photocopier machines 5 feet away messing with the normal use of a computer…electromagnetic interference is everywhere these days!

Let me know how things go!

It randomly happened to me, I reported it to Cetus and they immediately sent me two sets of limit switches and stepper motors as my printer is under warranty. I also experienced a layer shift and then followed by the motion error message.

While waiting for the kit, I disassembled the Z limit switch and found out it has become loose, which also causes random initialization faults. I checked the X and Y limit switches and they are still ok (no play). I tried to address the Z limit switch issue by putting in a spacer (piece of double adhesive tape) to push the limit switch arm to engage.

After doing this, the motion error went away, the kit arrived and I didn’t replace anything except the Z limit switch.

You did mention that your printer’s initialization always work, but I’d still check the limit switches first.


You did mention that you checked the limit switches, and based on your video, we can take UP Studio out of the equation. You’re using the hardware initialize switch and it still behaves that way. It looks to me like corrupted firmware, or worse malfunctioning stepper motor drivers. If it’s firmware, ask Jason for the Mk3 firmware and flash it again.


Mk3 firmware are actually here - https://support.tiertime.com/hc/en-us/articles/360003568353-Cetus-ROM-Update

@techsalad @Arnold Thank you so much for your response and suggestions!

@techsalad: Regarding point 1 and 2: I did not try this yet but as you can see in the next point, UpStudio seems not to be of relevance for this issue.
Point 3: I did try to route all wires away from the stepper motors (mainly the Z motor) and to have space in between them. It did not help.
Then I disconnected the Cetus from the USB and shut down my computer. Also no improvement.
Then I placed the Cetus far away in my basement. There is no electronics running there, only the Cetus and the room lights. Still the same issue…
Only thing I could try, regarding electromagnetic interference, is to shield the cables with aluminum foil… but this seems a bit silly to me.

@Arnold: I again tripple checked the limit switches. To me they seem to work properly.
If I press them by hand/finger, I hear a “click” sound and if I do it during the homing process, the Cetus immediately stops as he thinks he has reached the end of the axis. So this is working fine.
Also unscrewed the Z limit switch holder (the end cap) from the Z axis. There is no loose screw inside. The limit switch stays firmly in place.
Only thing I’m unsure about is, if the Z-Limit switch should always be in touch with the linear rails slide after the initialize process. On my printer the Z limit switch always stays “pressed” after the initialize process. On the X and Y axis the linear rail slide moves a bit away from the limit switches after it was pressed. I’m not sure anymore if this was the normal behavior for Cetus.

I also did the firmware flash.
Cetus connected via USB -> Turn Cetus on -> Reset Functions -> Reset Module -> Cetus ROM Update -> Choose “Cetus S11NTC_R_180524 MK3-EXT.ROM” -> The tool finishes successfully -> Shut Cetus down -> Turn Cetus on -> Same problem :frowning:

Other things I have tried:
Ckecked the SD Card in Windows -> No errors found.
Also tried another 64GB SD Card from my phone -> No difference.
Used the original 19V power supply and disconnected the extension board -> No difference.

By now I think its some defect on the motherboard or the stepper driver :disappointed_relieved:
Jason-TT: Would much appriciate if you or some other Support staff would get in touch with me to discuss a replacement. My Cetus MK3 is still under warranty after all.

On most machines using limit switches, the object that engages the limit switch should be moved enough to disengage and move away from the switch like it does for your x and y. On the MKII without limit switches, when initializing, the linear guide blocks always move a bit after hitting the physical stops.

Yes, I also think so. Sorry, I forgot that the MK2 is using a different method to set its limits.
Maybe some other MK3 user can (dis)confirm this behavior?
But if true, the question remains: Why is it not disengaged and how to fix it?

Anyhow, Jason Wu finally responded. They have no idea why this is happening but they offer me a replacement for the mainboard and cpu. I hope this will fix the issue very soon :slight_smile:

1 Like

Under warranty! Great! Looking forward to hear some positive update soon.

1 Like

We are not sure what happened, but should contacted you for sending replacement parts. If not please contact us again.


Good to hear this support issue is moving forward!

cheers and happy printing for everyone!

I got the replacement parts a few days ago.
Had to pay ~40€ for customs and taxes, which I did not expect. But I don’t blame Tiertime for it, they declared the package content perfectly fine. I just somehow thought replacement parts were free from customes in germany :sweat_smile:

But most importantly, my Cetus is working again!
First I switched the motherboard and the “strange movement” problem was gone immediately!
But I still had the issue in UpStudio telling me “Model Out of Print Range”. So I reinstalled it, deleted all remaining config files I could find and even installed it on a different notebook. But the error remained.
So I switched also the extension board. This did not changed anything.
Then I switched also the CPU. The new CPU worked as good as the old one (Homing works fine, no strange movements) but it showed a completely wrong nozzle and bed temperature of about 3000°C :open_mouth: So I switched back to the old one.
After some time I realised the “Model Out of Print Range” problem only occurs because I had not set the “calibration height” in UpStudio :sweat_smile:
The error makes totally sense if you have not set the height at all…
After the several reinstallations the height value was lost and I never thought about to calibrate it again…

So in conclusion:
The new Mainboard fixed the “strange movement” problem. :slightly_smiling_face:
The old extension board and CPU are fine.
The “Model Out of Print Range” problem was my fault. Just remember to calibrate your printer again.

Thanks to @Jason-TT and Tiertime support for sending me the replacement parts!
And thanks to techsalad and Arnold for trying to figure the problem out.

Happy printing!

Good to see you’re back to happy printing @Mambu!

Cheers and good journeys to you!

Glad to know you’re enjoying your Cetus again :wink:

1 Like

Good to know the printer is back to work!:grinning:

1 Like