Cetus MK3 grinds material, not able to print

Hi there,

I have purchased Cetus MK3 standard version last December.
Since then, all up hill. Its hard to print a component, its grinding filament and not passing it through the nozzle causing prints failure. It is getting to very frustrating moments as since I have the printer, I have used 5kg of material while, maybe, I got only 1kg of successful prints.

Printer prints raft, goes for about 1h and stops, than only moves around without extruding.
I have tried 4mm nozzle and 6mm nozzle without any success. Both softwares, UpStudio and UpStudio3. No difference. Please see pictures, the bearing next to extruding gear has made a mark on the extrusion stepper motor, is that normal ?

Printing parameters are as follow
0.2mm layers height
20% infill
Normal Speed
210°C printing
1.75mm PLA (Esun, Sunlu, Tiertime) no difference, same result an all.

Is there something fundamentally wrong with my printer ? how can I get it to work?


How do you locate the filament spool? Sometimes it is not the extruder, just the filament is not unreeling smoothly.
please contact support@tiertime.com for further asistance.