Can not connect to printer over WiFi

My Mini is on my wireless network. I see it’s IP from the front panel and get responses when I ping it from another machine on the network. When I try to connected in UpStudio I see the printer in the pull down list but it is greyed out. If I go to ‘Add Printer’ it does not appear in the list. I am able to connect and print via a USB cable but obviously that is not desired.

I did recently upgrade my router from Eero to an Ubnt EdgeRouter. Even though the local network is open I am guessing there is a port or some traffic I need to allow but I am not seeing anything in the docs. Any advice would be appreciated.

It is a weakness of the Wifi printing system that it doesn’t work with any network that doesn’t support multicast. Try using your phone as the Access Point between your computer and printer, and if that works, it’s your Wireless Access Point ( WAP ) that is causing the problem.

Try to enable multicast, but if that doesn’t work, then you are stuck.

The Tiertime Wifi solution seems to absolutely rely on multicast.

some guy on the old forum claimed to have made a proxy service for routed networks, but no details were ever published, so stick to switched networks that allow the broadcast traffic all over the same subnet.

Interesting notes about the multicast & broadcast traffic, I’ll look into that. Thanks!

For future reference - I was able to fix this issue on my network with these tutorials. Not sure which fixed it since it didn’t start working until this morning (after one of the changes propagated…)

  1. Enabled IGMP Proxy -
  2. Configured mDNS repeater -
1 Like

thats interesting; just to be on the up and up, the printer and your computer are on different networks that are routed?

No same network, 10.0.0.x/24. Ping was working from computer to printer previously but would not connect. It was not until after making changes from the links above that it started working via wifi

I get that often, I just leave ping running forever and it somehow keeps the printer on its toes preventing disconnects and as well as allowing the connection in the first place. Same broadcast domain, no filters or firewalls.


Guess I was wrong about those fixes. I am trying to use the printer today but again I see the greyed out printer in the list. I can not connect to it. Nothing has changed on the network since I made the updates above so I am not sure why it is broken again.

I am confident it is my network and not the printer but with the lack of documentation I am not sure what to do to fix it. Frustrating.

try the ping thing, i’m astonished it consistently helps improve the connectivity. latopt runs ping -t upmini at start up and it really makes a difference.

Seems like there was a setting I did not enable the first time which is needed for DNSmasq to work, “hostfile-update”. I changed this a few days ago and since the printer has been accessible via wifi without issue. :crossed_fingers:

For future reference I found what I needed in page 36 of this guide -