Axis Shift Mid Print?

Lost a 9 hour print due to an axis shift in the middle of the print (second time this has happened on different 3d models) What’s causing this? and more importantly how do i fix it?

The black dot there could indicate a collision causing skipped steps?

(although I’ve had similar problems attributed to version 2.6, reverting to 2.5 solved the issue as the “jump” speed setting was too fast to avoid skipped steps)

non-collision… happened again today halfway through an 11 hour print

please use fine mode or slow down the print speed by using custom material profile.
It is likely due to the wall structure in the print cause rapid back and forth movement that cause skipping steps. We have tuned down print speed in latest version and suppose should not happen.

i always have my prints set on “fine” mode, custom material profile refuses to open on my computer. I wish there was an easier way in the up studio software to slow down the print speed to help avoid the “jumping” or “skipping”

Are you using latest Mac version? If yes then you need to download the version from our website:


The update from Mac App store is not working and require reinstall from the latest version from website.
We are abandoning Mac App Store as it always change our codes and cause issues.

I am on windows. ver 2.6.43.627

afaik the print speed in up studio doesn’t affect the rapid moves, nor in current version catfish ; i had to go back to 2.5 to print

may have finally solved the issue. seems to have been an excess of grease/lube on the linear rails causing the axis to shift. havent had the issue in a few weeks now