0.2 nozzle


I've tried printing at 0.07 mm with the 0.4 nozzle, but it was soso, I expected that, so I changed to the smaller nozzle, but when it was printing, it kept making noise "clac clac" and I tried to print marvin at 0.07 mm, and it failed in the middle.

Here a video where you can hear the noise: https://www.youtube.com/watch?v=uMe207zvOqY

Hello Avri89,

did you change the nozzle setting in the maintenace section?

Sounds like extrusion is not being smooth.Could be a partially blocked nozzle or the printing temperature need to be increased. What is the material?

It's the PLA bought with the cetus. Btw when I switched back to the 0.4 mm nozzle, this is how the 0.2 nozzle looked like when I removed it: http://imgur.com/PFAPkya

looks like the plastic is getting out from the thread above the brass nozzle, the nozzle could be defective due the inproper sealing between the peek tube and the brass nozzle.

Pleasae send more pictures to support@cetus3d.com, we may able to send you a replacement very soon.

I don't see nozzle setting in the maintenace. I want to also use the .2mm nozzle, thanks!!

I might be in the same boat after trying everything else I can think of to fix that clicking noise with the .2mm nozzle. I finally saw this post and took it out. This is what happened to it. http://imgur.com/S6dWyN7

What this is looking and sounding like is an issue in the slicer. It's trying to force more plastic through the 0.2 nozzle than it can handle. The extrusion stepper stalls out which is the sound you're hearing. It also looks like the pressure is causing the seals to fail inside of the nozzle which would explain the red plastic in that last picture. Cetus will need to check the code in their slicer to see how they're dealing with the smaller nozzle size. I think I'll avoid trying the smaller nozzle until this gets sorted out.

Having the same issue. Must be in the slicer. 

Yep...Cetus needs to upate the 2.0mm nozzle splice settings..especially for the raft, the print itself is fine but getting through the raft first is painful.

When I tried the 0.2 nozzle at 0.07 layer height I also had issues. I had to increase the temp an extra 5 or 10 degrees to get it to print without having the extruder start clicking. The other issue I had is that the rafts were nearly impossible to remove. I finally dropped back to a 0.1 layer height and it's working much better. 

I would also like to know where the nozzle setting is in the maintenance settings. 

same issue has appeared since yesterday.

when I changed 0.2mm nozzle & 0.07mm resolution.

i'm in trouble.

I'm going to try to clean the nozzle today

BlueDinos 2017-3-14 01:05 edit

Yep it's the Slicer. It's trying to push out too much material so it clicks and pops. You can either up the temperature, or lower the speed...though you can only choose fine, which is still not slow enough....Simplify3D works perfectly with no clicking/popping since you have more control over extrusion, speed, temp, and raft.